EmailOctopus

500 errors via Cloudflare
Resolved·Partial outage

Following Cloudflare’s fix, the EmailOctopus website and Dashboard have now been loading reliably for an extended period of time.

We’ve seen no further errors and all systems are operating normally.

Fri, Dec 5, 2025, 09:23 AM
(18 hours ago)
·
Affected components
Platform
Updates

Resolved

Following Cloudflare’s fix, the EmailOctopus website and Dashboard have now been loading reliably for an extended period of time.

We’ve seen no further errors and all systems are operating normally.

Fri, Dec 5, 2025, 09:23 AM

Monitoring

Our upstream provider, Cloudflare, has implemented a fix and we’re now seeing pages loading reliably again.

We’ll continue to monitor performance to ensure everything remains stable.

Fri, Dec 5, 2025, 09:18 AM

Investigating

We’re currently seeing an increase in 500 errors being returned by Cloudflare when loading parts of the EmailOctopus website and Dashboard. Our team is investigating and working with Cloudflare to identify the cause.

Fri, Dec 5, 2025, 09:01 AM(16 minutes earlier)